ISSUE WITH CRANK PULLEY REBUILT EA71

Subaru Brat Discussions - HEY BRAT PEOPLE. If you have any ideas for the Brat section of the site, please PM jaxed!
Post Reply
dhopper340
Scoobytruck Lurker
Posts: 1
Joined: Thu May 09, 2024 11:49 am

ISSUE WITH CRANK PULLEY REBUILT EA71

Post by dhopper340 »

Hello All,

A little background. I bought a 79 Brat with an EA71 last year that had a bad piston. I pulled the motor and took it to a shop that specialized in Subaru engines which was recommended. They machined the heads and block and installed new pistons. I got the motor back from them and began the process of putting installing all of the accessories (new oil pump, water pump, clutch etc.). This is where I am running into my issue. When I brought the motor in the crank pulley was attached. When I brought the motor home they had removed it. Now the pulley does not seem to sit flush and does not align with the water pump pulley. I wish I would have taken more pictures of the motor before because I'm not really sure if it was like this before I took the motor in. The guy that did the work claims he doesn't know why it wouldn't line up and I could bring the motor back to him (it kind of a far drive) but I wanted to ask the community to see if it was something I could fix myself easy enough.

See attached pictures of misaligned crank pulley.

The picture of the pulley shows the original wear and another pic shows the shinny wear not seated.

Any help is greatly appreciated.
Attachments
CrankPulley3.jpg
CrankPulley3.jpg (244.99 KiB) Viewed 631 times
CrankPulley1.jpg
CrankPulley1.jpg (206.32 KiB) Viewed 631 times
Post Reply