Any problems with your Baja????

General talk about the Subaru Baja.

Moderator: mikenmel08

Post Reply
User avatar
mbaksic
Scoobytruck God
Posts: 559
Joined: Mon Dec 27, 2004 11:23 pm
Location: Mukwonago, Wisconsin

Any problems with your Baja????

Post by mbaksic » Sat Jan 15, 2005 8:12 pm

Ok, I think that it is time to see how well the Baja is holding up, now that they have been out for a few years. ;DHas anyone out there had a problem, weird or normal that they would like to report?? ::)I have NEVER had mine back to the dealership yet. I bought it with 17,000 miles on it in April 2004. The My Subaru, on Subaru's website, showed nothing at all except a recall being done to it. ;D I now am over 36,000 miles, and hoping for a good ownership experience with it. This is the first "Import" car I have owned. I like that term, since it is made in Indiana. ::)Before that, drove alot of Chevies and Dodges. Everyone put their 2 cents worth in please.   Mike
Even though I work on Dodges, I don't own one.

User avatar
03ClassicYellow
Scoobytruck Contributer
Posts: 30
Joined: Tue Jan 04, 2005 1:24 pm
Location: Manassas Virginia
Contact:

Re: Any problems with your Baja????

Post by 03ClassicYellow » Mon Jan 17, 2005 10:22 am

Well where should I start … <br>1)A/C has been fixed twice, The last time they replaced the system .I hope it hold<br>up this time  !<br>2)Drivers seat bolster was wearing through the frame and cutting it the leather . Replaced the seat bottom.<br>3)Rubber Floor Mats starting to crack .(Only had them for about 8 months .) <br>4)Crossbar for the bedcover the web type stuff that goes through it and holds the 2 clips is wearing out . This is a POC the way it is designed.<br> I have owned many Toyotas in the past  and own 3 Mazda’s now ( All were made in Japan) and have had NO problems. This goes to show you that cars made in the states don’t have the same quality standards as a true import.  <br>

User avatar
03ClassicYellow
Scoobytruck Contributer
Posts: 30
Joined: Tue Jan 04, 2005 1:24 pm
Location: Manassas Virginia
Contact:

Re: Any problems with your Baja????

Post by 03ClassicYellow » Mon Jan 17, 2005 10:25 am

Oh forgot to say I have had the Baja for 11 months and it has 18K on it.

User avatar
mbaksic
Scoobytruck God
Posts: 559
Joined: Mon Dec 27, 2004 11:23 pm
Location: Mukwonago, Wisconsin

Re: Any problems with your Baja????

Post by mbaksic » Mon Jan 17, 2005 7:58 pm

Wow, a bunch of weird ones!!! Hope the dealership gets it all straightened out for you soon, and it stays in good repair. I guess so far that I have been lucky, knock on wood.  Mike
Even though I work on Dodges, I don't own one.

User avatar
trbajalv
Scoobytruck Lurker
Posts: 6
Joined: Wed Mar 09, 2005 4:22 am
Location: North Las Vegas

Post by trbajalv » Thu Mar 24, 2005 10:15 am

How about late delivery, does that count. Waited on an order that was to be delivered last week and still no truck. :x

User avatar
mbaksic
Scoobytruck God
Posts: 559
Joined: Mon Dec 27, 2004 11:23 pm
Location: Mukwonago, Wisconsin

Post by mbaksic » Fri Mar 25, 2005 8:56 pm

Don't feel too bad. :( We get that all the time at the Dodge stealership I work at. Prolly just a screw up on the line somewhere. Hope you get yours soon, so you can have fun like the rest of us. :) Mike

phillybaja
Scoobytruck Contributer
Posts: 21
Joined: Fri Mar 25, 2005 4:39 pm
Location: philly

Post by phillybaja » Sat Mar 26, 2005 7:29 am

cd player didn't work - which i didn't know until the day after i bought it when it ate my marley cd. :shock:
dealer replaced the unit AND got bob back for me. :D

bought oct 30, 2004 and now have over 8500 miles on it.



EDIT: i did not buy my car in oct 05. ;)
Last edited by phillybaja on Sat Mar 26, 2005 8:15 am, edited 1 time in total.
2005 n/a monterey silver

User avatar
yellowblaze
Scoobytruck Master
Posts: 342
Joined: Mon Dec 27, 2004 3:36 pm

Post by yellowblaze » Sat Mar 26, 2005 8:07 am

Bought: dec 04 2,800 mi
Now: march 05 12,000mi

Brake fade/vibration after making a couple quick stops in a row
burning clutch smell (but its an a/t)
soft tonneau is coming apart at the corners

User avatar
cyphergirl
Scoobytruck Master
Posts: 165
Joined: Fri Jan 14, 2005 7:39 pm
Location: Mount Airy, MD
Contact:

Post by cyphergirl » Sat Mar 26, 2005 8:14 am

The soft tonneau cover is a POS.

User avatar
mbaksic
Scoobytruck God
Posts: 559
Joined: Mon Dec 27, 2004 11:23 pm
Location: Mukwonago, Wisconsin

Post by mbaksic » Sat Mar 26, 2005 10:58 am

Yeh, soft tonneau IS a POS, mine has frayed rear corners, but I didn't have it fixed under warranty. Had some patches sewed over the corners, will hold it for now. Hey yellowblaze, my brakes started to pulsate a bit just after I bought mine. I cut the rotors at work, and have not had a problem since. The rotors have cast into them MADE IN USA. Hell, we can't even get that from a Dodge, all of theirs are made in Canada. I consider brake pulsations normal wear and tear from driving. All cars have this problem. Might go to cross drilled when brakes need replacing. Mike

05bturbo

Post by 05bturbo » Sat Mar 26, 2005 8:55 pm

10,000 miles and Zero probs just had to wait for a new trim piece for the tailgate but the dealer gave me extras fast surefooted and reliable!!!

User avatar
BajaBear
Scoobytruck Contributer
Posts: 33
Joined: Thu May 05, 2005 4:09 pm
Location: Sacramento, California

Post by BajaBear » Thu May 12, 2005 8:56 pm

My driver's door sags a bit when I open it. There's also a squaling noise at 80+ when it's windy. Sounds like it's in the front vents. It alternates between driver & passenger sides. Go'N in next wk for a check-up.

opimax1
Scoobytruck Contributer
Posts: 25
Joined: Wed Mar 30, 2005 1:08 pm

Post by opimax1 » Fri May 13, 2005 6:51 am

1)4 rotors replaced 2nd week
2)door/window adj twice and now squeals when lowering
3)tires balanced 3 times, still not good,have appt w/SOA rep Tues the 24th to ride w/me
4)Whistling noise sounds like its coming from windshield at 60-70

Concerns
1)A/C not impressive, compressor cycles which many do but gets too warm before it comes back on
2)haven't gotten above 20mpg, na, driven to save gas
3)cold idle not quite 100%

foolish complaints

No heated mirrors

no heated seat availble (can they be taken from turbo?)

takes too long for tranny to go from reverse to drive

The stopping of the sun roof closing and having to hit button twice

Can't turn on heaqdlights car off?

may not souund like but I like this truck!!

Mark

User avatar
ScreaminMimi
Scoobytruck Contributer
Posts: 44
Joined: Thu Jan 27, 2005 6:51 pm
Location: Salem, Massachusetts

Post by ScreaminMimi » Fri May 13, 2005 5:15 pm

BajaBear wrote:My driver's door sags a bit when I open it. There's also a squaling noise at 80+ when it's windy. Sounds like it's in the front vents. It alternates between driver & passenger sides. Go'N in next wk for a check-up.

My door feels like it sags when I open with the window closed too, but if the window is down/open, it doesn't do it?! It may be something with the top part of the gasket? It may be actually pulling it up? It's weird, I can't quite put my finger on it.

I don't have any whistling noises. In fact, even my sunroof noise is little to none when open and I don't have a deflector installed.
'78 Brat Stock 4 sp.
Ford Chrome Yellow/Red Decals
'86 Brat - T-tops, low topper - primer grey
'05 Baja Turbo 5 sp.
Monterey Silver/Brilliant Silver

User avatar
mbaksic
Scoobytruck God
Posts: 559
Joined: Mon Dec 27, 2004 11:23 pm
Location: Mukwonago, Wisconsin

Post by mbaksic » Fri May 13, 2005 7:22 pm

Hey Screamin, thats the window putting pressure on the gasket with the window up. Then the door seems to drop when you open it when the pressure on the weatherstrip is relieved by the glass pulling away when the door opens. Mike

Post Reply