Search found 43 matches

by walfredo
Fri May 03, 2019 8:19 am
Forum: Technical Discussions
Topic: Problem when turning... diffrrential?
Replies: 7
Views: 637

Re: Problem when turning... diffrrential?

What axle did you replace the bad one with. If it was a remanufactured axle - those are junk and are commonly bad from the get-go. I made the mistake of trying them and ended up getting 3 bad ones in a row until I just said forget it and got an OEM used axle from the junkyard. I will never ever go w...
by walfredo
Fri May 03, 2019 8:12 am
Forum: Technical Discussions
Topic: New to subaru's
Replies: 9
Views: 828

Re: New to subaru's

Yup, all DIY. I'm no stranger to this kinda stuff, just didn't know if there was something specific to look out for. I just pulled the oil pan off of the donor engine from a 99 forester & everything looked good. The engine was $150 from the local pick a part. No sparkly stuff in the oil & the oil f...
by walfredo
Fri May 03, 2019 8:06 am
Forum: Technical Discussions
Topic: In need of a Spare Tire "Donut" for a 06 baja turbo
Replies: 18
Views: 4504

Re: In need of a Spare Tire "Donut" for a 06 baja turbo

145/80/16 is 25." diameter and 5.7" width

Wondering if you can run a 15" rim with a 195/65 tire instead which is 25" diameter and 7.7" wide (should still fit as long as diameter is the same no?)

Question is will 15" steelie rub on brake rotors (I know 15" aftermarket wheels like methods do not)
by walfredo
Fri May 03, 2019 8:01 am
Forum: Technical Discussions
Topic: Rear differential fluid
Replies: 5
Views: 570

Re: Rear differential fluid

+1 75W90
by walfredo
Thu Jan 31, 2019 7:19 am
Forum: Anything Baja
Topic: Repaint options...
Replies: 5
Views: 559

Re: Repaint options...

Dont forget about plastidip - Ive seen decent results and it peels right off - even easier than vinyl wrap.

If you live near a decent sized city/town you can usually find people who do it.
by walfredo
Wed Jan 09, 2019 11:16 am
Forum: Anything Baja
Topic: Well, I'm back...
Replies: 20
Views: 1676

Re: Well, I'm back...

I would double check that you have the OEM size restrictor pill - I think the correct size is in the link I posted earlier. If someone modded the car, they may have changed out the pill and could possibly now be the cause of your wastegate code. Just a thought. I suspect that you boom/misfire/limp i...
by walfredo
Tue Jan 08, 2019 9:34 am
Forum: Anything Baja
Topic: 2003 lift
Replies: 8
Views: 837

Re: 2003 lift

Keep in mind as well that the "King Springs" lift (from my understanding) is going to make your car stiffer and make ride a bit harsher. I opted not to do this because I wanted to maintain the softer ride and just went with spacers.
by walfredo
Tue Jan 08, 2019 9:19 am
Forum: Anything Baja
Topic: 2003 lift
Replies: 8
Views: 837

Re: 2003 lift

I also have a 2003, running a 1.5" lift in the front and 0.75" lift in the rear. I am also squeezing an additional 0.5" lift from the 215/70/16 tires (which doesnt affect axles/suspension geometry), which gives me a total lift of 2"/1.25" Anytime your camber changes (with a lift it tends to move to ...
by walfredo
Wed Jan 02, 2019 3:33 pm
Forum: Anything Baja
Topic: Well, I'm back...
Replies: 20
Views: 1676

Re: Well, I'm back...

Here is a good article for you to read and check all your mechanical hardware:
https://cobbtuning.atlassian.net/wiki/s ... stem+Works

Still gotta look for any vacuum leaks outside of the turbocharger system as well though
by walfredo
Wed Jan 02, 2019 2:18 pm
Forum: Anything Baja
Topic: Well, I'm back...
Replies: 20
Views: 1676

Re: Well, I'm back...

-What do you mean when you say fuel cut? -What do you mean by overboost? Is your boost spiking? (wastegate issue, vacuum/boost line issue, boost controller issue) -Do you have a boost controller of any kind? -Do you have a boost gauge? How much boost at full throttle? Steady consistent vacuum at idl...
by walfredo
Fri Dec 21, 2018 10:01 am
Forum: Technical Discussions
Topic: 2005 Baja Throwing P0462 Code
Replies: 3
Views: 586

Re: 2005 Baja Throwing P0462 Code

Sounds like a wiring issue related to the remote start. The fact your lights on the dash for temp and whatnot are not coming on would lead me to check that wiring and maybe even remove the remote start all together, and restore all the wiring to its original state.
by walfredo
Tue Dec 18, 2018 7:26 am
Forum: Technical Discussions
Topic: No heat
Replies: 19
Views: 1993

Re: No heat

Yeah you are probably sacrificing some of the min/max temp control due to the shorter "throw" of the control arm, but its free and it works.
by walfredo
Thu Dec 13, 2018 7:35 am
Forum: Technical Discussions
Topic: No heat
Replies: 19
Views: 1993

Re: No heat

Hey tsmart, mine broke almost exactly where yours did. I drilled a new hole at the red dot (see attached pic). Your local pick and pull probably has a Legacy you can snag one from as well:
Inked20181212_150720_LI.jpg
Inked20181212_150720_LI.jpg (3.38 MiB) Viewed 556 times
by walfredo
Wed Dec 12, 2018 11:38 am
Forum: Technical Discussions
Topic: No heat
Replies: 19
Views: 1993

Re: No heat

Yes there should be some resistance to your temp control knob. If it feels loose, its probably the plastic arm that is broken, exactly as mine did. Very easy to check. The clip for the cable sheath is also easy to find, its underneath your dash near the glove box. You should be able to trace the cab...
by walfredo
Tue Dec 11, 2018 2:10 pm
Forum: Technical Discussions
Topic: No heat
Replies: 19
Views: 1993

Re: No heat

How are you so sure that "no hot water is making it to the heater"? (you can easily determine this by putting your hand on the coolant line running into and out of your fire wall and see if its hot). The more likely scenario is that, your temperature control isn't working, so its blowing cold. First...